Ritualistic Forums

Ritualistic Forums (http://www.ritualistic.com/forums/index.php)
-   EF2 Tech Help (http://www.ritualistic.com/forums/forumdisplay.php?f=16)
-   -   Video Problem--Please Help! (http://www.ritualistic.com/forums/showthread.php?t=20313)

WinstonSmith6079 12-04-2009 06:41 PM

Video Problem--Please Help!
 
As I run around the map on the very first mission (just after the tutorial), often times the walls--and even objects too--in an area in front of me will disappear, revealing what I assume is beyond the outermost walls of the map on all sides: It looks like maybe a Borg hive at a great distance. Or maybe what I'm seeing is just glitched video crap--I can't be sure. Sometimes, if I look away slightly, the glitched area will go away and the walls and objects will return. Look back, and the glitch returns. This does not happen in the tutorial part of the game.

If the above sounds vague, well I dunno how to make a screenshot in this game to show you exactly what I mean.

I've had this problem with this game on another computer, so it must be a problem in the game software (I guess).

I'm running the game on WinXP Pro w/ SP3. I'm using a GeForce4 Ti 4600 @ 128MB VRAM, and that with the latest drivers.

Please help! :O

Chriss 12-05-2009 02:41 AM

Re: Video Problem--Please Help!
 
There are two options I can think of:
  1. Your Drivers do not well with the Game (your driver is not supporting OpenGL the way it should!)
  2. A other software is interfering.

I suggest you first try to disable all other software before you try other drivers.
Shut down all other software!
Software that is know to create effects like this:
  • Screen/Desktop Recoder (especially the Free Software)
  • In-Game Recorder (especially the Free Software)
  • Video Player (especially VLC)
  • Instant Messenger (especially MSN!)
  • Other Games
  • Tunning Tools
  • Vista Specials like 3d Effects (try to run the game in full-screen)


Please provide a screenshot first before you do anything on the drivers software (Ingame Press [F11]), they are saved in:
C:\Program Files\Activision\EF2\base\screenshots\ (english version)
C:\Programe\Activision\EF2\base\screenshots\ (german version)

If you have troubles to open the screenshots you can use Irfan View to open them
(free and clan, I use it my self since years)

WinstonSmith6079 12-07-2009 04:59 PM

Re: Video Problem--Please Help!
 
Thanks for replying.

Okay, I d/led the IrfanView, installed it, snapped the screenshots, converted them from .TGA to .JPG, posted them on Photobucket.com for hosting, and can now post them here.

Here's some pics of the problem:
(Click the thumbnails for the bigger picture.)



[Continued in next post....]

WinstonSmith6079 12-07-2009 05:09 PM

Re: Video Problem--Please Help!
 
[More pics; continued from last.]



Upon closer examination of the pics, the interfering glitch looks like a Borg hive. :/

What's going on here? Please help me fix this so I can play what seems to be a great game without problems. Please help! :O

Chriss 12-07-2009 05:53 PM

Re: Video Problem--Please Help!
 
I have to admit that I have never seen anything like it.
It looks like a openGL problem.

The command r_fastsky set to 1 could maybe help you out(seta r_fastsky 1).
You can past text into the console by pressing the middle mouse button.
Link: Introducing the game console

If nothing did help so far...
You might want to check for newer or older drivers for your graphics card, but make sure you de-install the current driver correctly.
Download first new drivers for your graphics card, if you have the latest drivers get some older drivers.

WinstonSmith6079 12-10-2009 04:09 PM

Re: Video Problem--Please Help!
 
Oh-no! Is there anyone who's seen like what's in the pics? Is there someone who can help me? Please help me, please! :(

Chriss 12-11-2009 07:33 AM

Re: Video Problem--Please Help!
 
Quote:

Originally Posted by WinstonSmith6079 (Post 178788)
Oh-no! Is there anyone who's seen like what's in the pics? Is there someone who can help me? Please help me, please! :(

Please try the things above stated.

WinstonSmith6079 12-15-2009 05:14 PM

Re: Video Problem--Please Help!
 
Okay. I'll try.

By that, instead of entering the command into the console during the game, is there a way I can boot the game with the command? You know, like putting it into the game's shortcut. Maybe the command line would be, like:

EF2.EXE -r_fastsky 1

?

Thanks in advance. I'll try the command and post back here with the results....

Chriss 12-15-2009 05:18 PM

Re: Video Problem--Please Help!
 
Yes.
In the short cut at "target" after \EF2.exe" add: +r_fastsky 1

Chriss 12-22-2009 05:23 AM

Re: Video Problem--Please Help!
 
Did anything help for you ?

WinstonSmith6079 10-16-2010 12:46 AM

Re: Video Problem--Please Help!
 
Yes, it did help, but only somewhat. It corected the problem but created a different other video problem. Sometimes backgrounds would be not shown, just blank, black screen in which the models and all are set against.

Like at the end of that first Borg round, when you beat it, the ship leaves the Sphere to join several other UFP ships. The background is supposed to be pretty stars and nebulas and cool space stuff. But, as I said, that background is not shown.

Likewise at Starfleet Academy when you look out of a window or go outside one of the buildings, there's nothing in the horizon or sky but pitch-black starless night. :/

But nevermind that: That computer that I had that problem with died and now I'm using a different computer with a completely different video-card. So I don't have any of those problems anymore.

I do, however, have a much differnet problem. I guess I should make a new thread for that.... Here it is:
http://www.ritualistic.com/forums/sh...220#post179220

Chriss 10-16-2010 06:43 AM

Re: Video Problem--Please Help!
 
Quote:

Originally Posted by WinstonSmith6079 (Post 179219)
Sometimes backgrounds would be not shown, just blank, black screen in which the models and all are set against.

Enter the following command into the game console: r_fastsky 0
Remove +r_fastsky 1 from your shortcut


All times are GMT -5. The time now is 01:07 PM.

Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.