Ritualistic Forums

Ritualistic Forums (http://www.ritualistic.com/forums/index.php)
-   SiN Episodes Tech Help (http://www.ritualistic.com/forums/forumdisplay.php?f=24)
-   -   key binding? (http://www.ritualistic.com/forums/showthread.php?t=18202)

Riftaxe 07-14-2006 01:43 AM

key binding?
 
Sin Emergence:

I am unable to make the turn left and right keys functional. I can bind them fine in the options, it just has no effect, regardless of what key i assign them to.

Is this broken?

Is there any workaround for this? This is a game breaking bug for me, since i cannot use mouselook. Running backwards and forwards only lets you play for the first room and only to the wall, i would dearly love to be able to turn left or right.

Sarkie 07-14-2006 02:36 AM

Re: key binding?
 
Odd, have you got a gamepad installed?

Have you tried deleting the .cfg files, try running Sin Episodes with the "-autoconfig" parameter, it is in advanced options.

Very odd .......

Apprentice 07-14-2006 01:45 PM

Quote:

Originally Posted by Sarkie
Very odd .......

....... but not unheard of. For some reason, the game doesn't want to save additional keybindings made in the console . . .

Riftaxe 07-14-2006 01:53 PM

Re: key binding?
 
no gamepad or joystick installed.

deleted config.cfg, no luck

tried -autoconfig on the command line, no luck

It updates the config.cfg file properly, so the keys that i bind are persistent. Ie, if i bind a turn movement to right arrow and left to mouse button 1. The new config.cfg file will have

bind "UPARROW" "+forward"
bind "DOWNARROW" "+back"
bind "RIGHTARROW" "+right"
bind "MOUSE1" "+left"

The only problem is that while it will go forward and backwards, it ignores turning left or right no matter what key or button i bind to it.


I have not tried binding in the console screen, as i would assume that if the game is smart enough to record the key bindings through the options screens (yes they are persistent) that would be enough.

Any other suggestions,

Riftaxe 07-14-2006 02:17 PM

Re: key binding?
 
By enabling the console, but not making any changes within it, when i use the SE1 engine to change the keyboard bindings, it does display


Initializing renderer...
Failed to load sound "npc/sintek/vo/grunt_death4.wav", file probably missing from disk/repository
couldn't exec userconfig.cfg
Wrote cfg/config.cfg
couldn't exec userconfig.cfg
Wrote cfg/config.cfg


This might just be trash debug code left in, but it does update the config file.

So far only the turn left/right and the look up and down key are not functioning....sadly no way to tell if swim up or swim down will work when i bind a key to them.

This is fresh install with the same problem. All my other HL2 based games are able to bind to whatever keys i assign to the turn left/right keys...this is annoying :confused:

Sarkie 07-14-2006 02:37 PM

Re: key binding?
 
Right I think its the version of Source they are using, I'd guess it will be fixed in future updates, just use your mouse or something till then. Sorry :(

Riftaxe 07-14-2006 02:39 PM

Re: key binding?
 
from console window.


] unbind a
] bind a
"a" = ""
] bind a +left
] bind a
"a" = "+left"


and still does not work.

Riftaxe 07-14-2006 02:41 PM

Re: key binding?
 
Quote:

Originally Posted by Sarkie
Right I think its the version of Source they are using, I'd guess it will be fixed in future updates, just use your mouse or something till then. Sorry :(

Who is "They"? Ritual?

Can you give me a link to the official tech support forum for SE1?

as i said this is very annoying.

Michael_Russell 07-14-2006 07:52 PM

Re: key binding?
 
In v1.3, there is a bug where +turnleft and +turnright do not work if the mouse is enabled.

This will be corrected in v1.4.


All times are GMT -5. The time now is 06:33 PM.

Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.