Ritualistic Forums

Ritualistic Forums (http://www.ritualistic.com/forums/index.php)
-   SiN Episodes Tech Help (http://www.ritualistic.com/forums/forumdisplay.php?f=24)
-   -   choppy game (http://www.ritualistic.com/forums/showthread.php?t=18579)

vett 09-16-2006 10:32 AM

choppy game
 
How do I fix the game when it runs choppy, I have lowered everything I could think of. I am running XP, nvidia 5700le

Curly 09-16-2006 10:52 AM

Re: choppy game
 
Quote:

Originally Posted by vett (Post 173184)
How do I fix the game when it runs choppy, I have lowered everything I could think of. I am running XP, nvidia 5700le

Here's a good tweak guide for improving performance.
It's not specific to Sin episodes but everything still
applies.

http://www.tweakguides.com/HL2_8.html

Sarkie 09-16-2006 01:30 PM

Re: choppy game
 
Also what CPU are you running?

vett 09-17-2006 09:40 AM

Re: choppy game
 
dell, pentiam 4

Sarkie 09-18-2006 06:47 AM

Re: choppy game
 
Well what things have you turned down?
Do you know the full specs of your machine?

vett 09-18-2006 08:18 AM

Re: choppy game
 
I have put everything on low like detail, shadows etc. I have a dell 4300, pent.4 1.60mgh, nvidia 5700le card, XP pro, 512mb ram. dose that help?

Grandpapa 09-18-2006 08:33 AM

Re: choppy game
 
I would suggest you to defrag your drives, and turning off all unnecessary programs running from the backround. Can't give any better advices without seeing your comp.

vett 09-18-2006 08:35 AM

Re: choppy game
 
I have already done the frag thing and don't know what to shut off?

Grandpapa 09-18-2006 08:53 AM

Re: choppy game
 
See if there is anything helpfull to you, but if you are not sure what to do, then don't do it.

Grandpapa 09-18-2006 08:54 AM

Re: choppy game
 
Forgot to add link http://www.tweakhound.com/xp/xptweaks/supertweaks1.htm

vett 09-18-2006 11:19 AM

Re: choppy game
 
Thanks but a little to advanced for me.

ChaosBahamut 09-23-2006 07:50 PM

Re: choppy game
 
Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.

Pa3PyX 10-31-2006 03:29 AM

Re: choppy game
 
Quote:

Originally Posted by ChaosBahamut (Post 173334)
Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.

Not quite accurate I think; should be +mat_dxlevel 81 as a command line option. And all 5700 chips default to 8.1 already. But I have Athlon XP at 1900 MHz and FX 5700 Ultra and it's barely playable still (although comparable to HL2 of course).

1) In your GeForce control panel (right click display / Properties / Advanced / GeForce FX 5700 tab -- in newer drivers (v90 and above I believe) you have to click Control PAnel User Interface -> Classic nVidia Control Panel to enable the rest of the options there because they have an alternate GUI somewhere -- select Performance & Quality Settings, and set the slider to "High Performance".

2) Further, select View: Advanced Settings, set Trilinear Optimization: On, Anisotropic Sample Optimization: On, Anisotropic Mip Filter Optimization: Off. If you have RivaTuner installed, also adjust mipmap LOD bias to 0.3. You can now use decent quality anisotropic filter without much performance tax.

3) The most performance taxing option in SiN (and HL2) appears to be water, when set to Reflect All (r_waterforcereflectentities "1", r_waterforceexpensive "1"); make sure you select Simple Reflections (r_waterforcereflectentities "0", r_waterforceexpensive "0") or Reflect World (r_waterforcereflectentities "0", r_waterforceexpensive "1") instead -- due to a bug in the Source engine and material definitions, they are equivalent in DX8 modes -- if $forceExpensive is not defined for a material, r_waterforceexpensive "1" does not enable shader reflections either, nor does r_waterforceexpensive "0" disable them).

4) Do not set Texture Detail to "High" (mat_picmip "0") unless you have at least 1024M of RAM; use Medium/Low (mat_picmip "1" or "2") instead. nVidia drivers (unlike 3Dfx BTW) are system memory hogs.

5) As a last resort, set DX level to 7.0 (command line: +mat_dxlevel 70; console: mat_dxlevel 70, if you cannot do it in the Advanced Video Options menu for some reason). You will lose water reflections altogether.

Pa3PyX 10-31-2006 03:29 AM

Re: choppy game
 
Quote:

Originally Posted by ChaosBahamut (Post 173334)
Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.

Not quite accurate I think; should be +mat_dxlevel 81 as a command line option. And all 5700 chips default to 8.1 already. But I have Athlon XP at 1900 MHz and FX 5700 Ultra and it's barely playable still (although comparable to HL2 of course).

1) In your GeForce control panel (right click display / Properties / Advanced / GeForce FX 5700 tab -- in newer drivers (v90 and above I believe) you have to click Control PAnel User Interface -> Classic nVidia Control Panel to enable the rest of the options there because they have an alternate GUI somewhere -- select Performance & Quality Settings, and set the slider to "High Performance".

2) Further, select View: Advanced Settings, set Trilinear Optimization: On, Anisotropic Sample Optimization: On, Anisotropic Mip Filter Optimization: Off. If you have RivaTuner installed, also adjust mipmap LOD bias to 0.3. You can now use decent quality anisotropic filter without much performance tax.

3) The most performance taxing option in SiN (and HL2) appears to be water, when set to Reflect All (r_waterforcereflectentities "1", r_waterforceexpensive "1"); make sure you select Simple Reflections (r_waterforcereflectentities "0", r_waterforceexpensive "0") or Reflect World (r_waterforcereflectentities "0", r_waterforceexpensive "1") instead -- due to a bug in the Source engine and material definitions, they are equivalent in DX8 modes -- if $forceExpensive is not defined for a material, r_waterforceexpensive "1" does not enable shader reflections either, nor does r_waterforceexpensive "0" disable them).

4) Do not set Texture Detail to "High" (mat_picmip "0") unless you have at least 1024M of RAM; use Medium/Low (mat_picmip "1" or "2") instead. nVidia drivers (unlike 3Dfx BTW) are system memory hogs.

5) Lower resolution; on the first blush it does not seem to affect much because video RAM bandwidth rarely is a bottleneck on modern video boards, but it does become a bottleneck for per pixel operations (blending -- smoke, fog; pixel shaders -- water reflection/refraction for instance) in high resolutions (above 1024 for 768 for my board, probably lower than that for yours). 1600x1200 and 640x480 may be equally fast in water-free area, but as soon as water is in the view, you will notice quite considerable difference.

6) As a last resort, set DX level to 7.0 (command line: +mat_dxlevel 70; console: mat_dxlevel 70, if you cannot do it in the Advanced Video Options menu for some reason). You will lose water reflections altogether.


All times are GMT -5. The time now is 10:06 AM.

Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.