Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > Condition Zero & CS Xbox

Reply
 
Thread Tools Display Modes
Old 09-20-2004, 11:56 AM   #1
Grantax
Casual
 
Join Date: Sep 2004
Posts: 29
Default func_train stopping

I've made a func_conveyor map, in a tunnel, then i placed lights (texture light), as func_train, so i tested it, but suddenly it stops for about 2 seconds, then it keeps moving..

I have 4 corners (i don't know what the entity is called) where the light goes, all of the is outside the tunnel..



Ok, heres the tunnel, 1, 2, 3 and 4 is the path_corners, the S is where the light stops
is goes from 1 to 2 with a speed on 1000, and it goes from 2 to 3 to 4 to 1 in 9999, then it starts over.

Edit: I didn't mean that it just starts moving again after 2 seconds, it jumps to path_corner 2..
Grantax is offline   Reply With Quote
Old 09-20-2004, 01:07 PM   #2
Michele
Regular
 
Michele's Avatar
 
Join Date: Mar 2004
Location: Parma, Italy
Posts: 74
Default Re: func_train stopping

Just two quick things:you can put your map on the TWHL site, in the Map vault->problem section:
http://cariad.co.za/twhl/index.php?start=0
if you wont to people download your map to help you better.

Otherwise you can take a look at Kiltron's map Swamp (that has the source .map released) or, if you have QuArK, you can see how Trainrun (by Kiltron) work.

http://collective.valve-erc.com/inde...ent=func_train
here is the tutorial on the func_train
Michele is offline   Reply With Quote
Old 09-20-2004, 03:59 PM   #3
Grantax
Casual
 
Join Date: Sep 2004
Posts: 29
Default Re: func_train stopping

I replied to this a long time ago but it seems like my post has gotten deleted, anyway: I've uploaded the map now, i named it Underground, if you didn't understand the tunnel picture, the it's a "picture" from the side...
Grantax is offline   Reply With Quote
Old 09-21-2004, 04:27 AM   #4
Michele
Regular
 
Michele's Avatar
 
Join Date: Mar 2004
Location: Parma, Italy
Posts: 74
Default Re: func_train stopping

Maybe it can be the same problem that i found. How long is the tunnel? It goes from one side of the map to the other? In that case, the "error" is done that the func_train entities must be placed in the middle of the used map space.

But, i'll download the map and i'll try.
Michele is offline   Reply With Quote
Old 09-22-2004, 05:51 AM   #5
Michele
Regular
 
Michele's Avatar
 
Join Date: Mar 2004
Location: Parma, Italy
Posts: 74
Default Re: func_train stopping

Downloaded and tried the map.
Yes, i was right. The problem is that the func_train light is placed near the end of the tunnel; you must place it at the middle of the map and it work right.
Just two small suggestion. the compiler log says that some path_corner are outside the world and hlcsg cannot compile.
Ensure to put the entities first inside the world space.
Another thing, is better if you build brushes using the grid, and, generally for walls, with a thickness of 16 units.
Michele is offline   Reply With Quote
Old 09-22-2004, 10:40 AM   #6
Grantax
Casual
 
Join Date: Sep 2004
Posts: 29
Default Re: func_train stopping

I'm not going to put the path_corners inside the tunnel, but something outside them..

But where does the light start, does it start where i place it, or does it start on the first stop target?

And what do i have to do when i want to place lights light the whole tunnel?
Grantax is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:30 PM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.