Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > SiN Episodes > SiN Episodes Tech Help

Reply
 
Thread Tools Display Modes
Old 05-18-2006, 10:19 AM   #1
Superfly
Regular
 
Join Date: May 2006
Posts: 63
Default Audio hitching - investigation and test results:

I like a lot of guys have always suffered some sound hitching in Source based games, Parnic asked users willing to try the following steps http://developer.valvesoftware.com/wiki/Stuttering to povide some feedback so here I am.

First I guess you want system specs:

A643500+
2Gb DDR 400 2-2-2-5
X-Fi Sound Card
Dual Leadtek 7600GT Extreme's in SLi
NF4 SLi MoBo

I tested every suggestion on that page, results as follows:

mat_forcemanagedtextureintohardware 1 (has no effect on the game at all) left it on for sake of it.

mat_forcehardwaresync 0 (not seen this one before - might be good but I need to do more testing tonight)

snd_async_fullyasync 1 (caused horrible sync issues - not advised at all)

cl_forcepreload 1 (has no obvious effect on anything)

sv_forcepreload 1 (again has no effect)

cl_smooth 0 (no effect)

snd_mixahead (value of 0-1 in tenths) (anything above 0.1 causes a delay on audio events and it does'nt help the hitching) setting this to -1 however may well help me, again I need to test this further tonight.

mat_loadtextures (this stops the hitching completely) also turns the whole game pink and black.

My page file usage was consistant thougout testing, I have'nt tried switching this off yet though.

I have PCIe GPU's so PCI latancy and AGP aparature are meaningless.

All drivers, fireware & bios's are upto date, I have access to NVIDIA's developer website and as such am often testing/running BETA drivers well ahead of the current public releases.

Harddrives are setup as fast as can be and are all defragged every other day.

Audio Codec priorities have been changed as suggested by Valve - this makes no difference.

So to summarize there are two console commands that may help, they are snd_mixahead -1 & mat_forcehardwaresync 0 but I need to start a new game and run through a good chunk tonight to see if there is really any difference.

With HL2 the only thing that ever made any difference for me was the recent patch that supposedly fixed it, it "mostly" fixed it in my case. I would think we are at the mercy of a code update from Valve/Ritual to bring us in line with that HL2 patch before things start to get much better.

If you have any questions or want me to test anything else please let me know, I'll update this post with tonights results when I can.

Thanks.


Superfly is offline   Reply With Quote
Old 05-18-2006, 10:58 AM   #2
Normality
Quality Assurance
 
Normality's Avatar
 
Join Date: Sep 2005
Location: Dallas, Tx
Posts: 15
Default Re: Audio hitching - investigation and test result

This is a great post and we appreciate you looking into this, we are going to continue to work on the issue and hopefully in the future have a fix that works for more people. As stated by Michael and Parnic the fix that went up in the first patch has actually helped quite a few individuals so we are starting to "defeat" the problem. Hopefully with some more time we will be able to help the rest of the people with bad stuttering out.

Also I know you still have the issue as you stated, have you by-chance tried the PCI Latency fix? That may or maynot help you.
Normality is offline   Reply With Quote
Old 05-18-2006, 11:19 AM   #3
Superfly
Regular
 
Join Date: May 2006
Posts: 63
Default Re: Audio hitching - investigation and test result

Hi Joel,

I hav'nt been near the PCI Latency tool, Its my understanding that this would have no effect on a PCIe card.

If of course im wrong and you would like me to test it then of course I will.

I would like to finish my testing on those two console variables before I move onto anything else though, I'll get this all finished up tonight.

thanks.
Superfly is offline   Reply With Quote
Old 05-18-2006, 01:17 PM   #4
Parnic
Programmer, Gearbox Software
 
Parnic's Avatar
 
Join Date: Nov 2005
Posts: 231
Default Re: Audio hitching - investigation and test result

Quote:
Originally posted by Superfly:
snd_mixahead (value of 0-1 in tenths) (anything above 0.1 causes a delay on audio events and it does'nt help the hitching) setting this to -1 however may well help me, again I need to test this further tonight.
-1 isn't actually what they are asking. They mean set it between 0 and 1 in tenths, so 0.1, 0.2, 0.3 ... 0.9, 1.0. Setting it to -1 may turn out to be bad [img]/forums/images/graemlins/tongue.gif[/img].
Parnic is offline   Reply With Quote
Old 05-18-2006, 01:22 PM   #5
Superfly
Regular
 
Join Date: May 2006
Posts: 63
Default Re: Audio hitching - investigation and test result

Yeh I got what they meant - setting anything above 0.1 produces audio latency which was not so good, the www.tweakguides.com HL2 guide suggests that using -1 disables all sound mixahead and can provide a slight performance boost - I tried it simply because any other setting made the audio de-sync.

hope that makes sense.
Superfly is offline   Reply With Quote
Old 05-18-2006, 01:24 PM   #6
Parnic
Programmer, Gearbox Software
 
Parnic's Avatar
 
Join Date: Nov 2005
Posts: 231
Default Re: Audio hitching - investigation and test result

Ah, gotcha. Just making sure - didn't want you damaging anything on our account. [img]/forums/images/graemlins/smile.gif[/img] Thanks for the feedback!
Parnic is offline   Reply With Quote
Old 05-18-2006, 04:30 PM   #7
Superfly
Regular
 
Join Date: May 2006
Posts: 63
Default Re: Audio hitching - investigation and test result

OK back with some updates:

snd-mixahead is a bit of a weird setting, @ anything over 0.1 adds an annoying delay to the sound effects, anything below 0 causes some popping. (in short leave this setting alone)

I might have to take back something I said earlier about snd_async_fullyasync 1 - as long as you hav'nt messed about with mixahead this setting seems quite useful, I've not come accross any sync issues yet - it does'nt remove the stuttering but it does help and that alone is no bad thing.

My suggestions to anyone with this issue would be to add the following into an autoexec.cfg file:

1. mat_forcemanagedtextureintohardware 1

2. snd_async_fullyasync 1

Last thing to test os the PCI latency tool (I'll be back)

thanks for listening.
Superfly is offline   Reply With Quote
Old 05-18-2006, 04:58 PM   #8
Superfly
Regular
 
Join Date: May 2006
Posts: 63
Default Re: Audio hitching - investigation and test result

Ok Final update - the PCI latency tool might be useful to those on old AGP systems, PCIe cards dont have latency timers so this tool did nothing for me.

I would love to hear the experiences of other users with audio hitching - im sure the dev's could use at much information as they can get.

thanks for listening all - ttfn.
Superfly is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:36 AM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.