Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > SiN Episodes > SiN Episodes Tech Help

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-11-2006, 01:33 PM   #1
junkiiii
Newbie
 
Join Date: May 2006
Posts: 8
Default Performance

My specs are not top of the line but I don't think i should be having problems running this game. I run everything I have including the likes of Half Life 2 and Call of Duty 2 on my system with all of the options on high except for Anti Aliasing and the Anisotropic Texturing (sp).

I run may games on 16:10 widescreen on 1280x768 since this is what my HDTV supports. Everything looks great and was playing fine until I got to the dock area and then there was a pretty significant frame rate hit. So of course the first thing I do is start playing with my settings. I set shadows to low, nothing. Textures to low, nothing. Set the res to 1024x768(stretched), nothing. I end up turning everything to low and there is no difference in the frame rate. This leads me to believe that this is not an issue with my system. All of my drivers are up to date. Anyone having similar issues? Below are my specs.

P4 3.0GHZ
1GB RAM
Nvidia GeForce 6600GT/128mb RAM by eVGA(direct x9 capable)
120GB HD
Sound Blaster Audigy 2ZS
junkiiii is offline   Reply With Quote
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:24 AM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.