Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > SiN Episodes > SiN Episodes Tech Help

Reply
 
Thread Tools Display Modes
Old 09-16-2006, 10:32 AM   #1
vett
Newbie
 
Join Date: Sep 2006
Posts: 5
Default choppy game

How do I fix the game when it runs choppy, I have lowered everything I could think of. I am running XP, nvidia 5700le
vett is offline   Reply With Quote
Old 09-16-2006, 10:52 AM   #2
Curly
Regular
 
Curly's Avatar
 
Join Date: Apr 2006
Posts: 94
Default Re: choppy game

Quote:
Originally Posted by vett View Post
How do I fix the game when it runs choppy, I have lowered everything I could think of. I am running XP, nvidia 5700le
Here's a good tweak guide for improving performance.
It's not specific to Sin episodes but everything still
applies.

http://www.tweakguides.com/HL2_8.html
Curly is offline   Reply With Quote
Old 09-16-2006, 01:30 PM   #3
Sarkie
Community Moderator
 
Sarkie's Avatar
 
Join Date: Apr 2006
Posts: 360
Default Re: choppy game

Also what CPU are you running?

--------------------
Sarkie
http://sarkies.blogspot.com/
Sarkie is offline   Reply With Quote
Old 09-17-2006, 09:40 AM   #4
vett
Newbie
 
Join Date: Sep 2006
Posts: 5
Default Re: choppy game

dell, pentiam 4
vett is offline   Reply With Quote
Old 09-18-2006, 06:47 AM   #5
Sarkie
Community Moderator
 
Sarkie's Avatar
 
Join Date: Apr 2006
Posts: 360
Default Re: choppy game

Well what things have you turned down?
Do you know the full specs of your machine?

--------------------
Sarkie
http://sarkies.blogspot.com/
Sarkie is offline   Reply With Quote
Old 09-18-2006, 08:18 AM   #6
vett
Newbie
 
Join Date: Sep 2006
Posts: 5
Default Re: choppy game

I have put everything on low like detail, shadows etc. I have a dell 4300, pent.4 1.60mgh, nvidia 5700le card, XP pro, 512mb ram. dose that help?
vett is offline   Reply With Quote
Old 09-18-2006, 08:33 AM   #7
Grandpapa
Fanatic
 
Grandpapa's Avatar
 
Join Date: Sep 1999
Location: Northern side of the earth.
Posts: 2,181
Default Re: choppy game

I would suggest you to defrag your drives, and turning off all unnecessary programs running from the backround. Can't give any better advices without seeing your comp.
Grandpapa is offline   Reply With Quote
Old 09-18-2006, 08:35 AM   #8
vett
Newbie
 
Join Date: Sep 2006
Posts: 5
Default Re: choppy game

I have already done the frag thing and don't know what to shut off?
vett is offline   Reply With Quote
Old 09-18-2006, 08:53 AM   #9
Grandpapa
Fanatic
 
Grandpapa's Avatar
 
Join Date: Sep 1999
Location: Northern side of the earth.
Posts: 2,181
Default Re: choppy game

See if there is anything helpfull to you, but if you are not sure what to do, then don't do it.
Grandpapa is offline   Reply With Quote
Old 09-18-2006, 08:54 AM   #10
Grandpapa
Fanatic
 
Grandpapa's Avatar
 
Join Date: Sep 1999
Location: Northern side of the earth.
Posts: 2,181
Default Re: choppy game

Forgot to add link http://www.tweakhound.com/xp/xptweaks/supertweaks1.htm
Grandpapa is offline   Reply With Quote
Old 09-18-2006, 11:19 AM   #11
vett
Newbie
 
Join Date: Sep 2006
Posts: 5
Default Re: choppy game

Thanks but a little to advanced for me.
vett is offline   Reply With Quote
Old 09-23-2006, 07:50 PM   #12
ChaosBahamut
Rookie
 
ChaosBahamut's Avatar
 
Join Date: Jul 2006
Location: Empire State
Posts: 19
Default Re: choppy game

Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.
ChaosBahamut is offline   Reply With Quote
Old 10-31-2006, 03:29 AM   #13
Pa3PyX
Casual
 
Pa3PyX's Avatar
 
Join Date: Oct 2006
Posts: 25
Send a message via ICQ to Pa3PyX Send a message via AIM to Pa3PyX Send a message via Yahoo to Pa3PyX
Default Re: choppy game

Quote:
Originally Posted by ChaosBahamut View Post
Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.
Not quite accurate I think; should be +mat_dxlevel 81 as a command line option. And all 5700 chips default to 8.1 already. But I have Athlon XP at 1900 MHz and FX 5700 Ultra and it's barely playable still (although comparable to HL2 of course).

1) In your GeForce control panel (right click display / Properties / Advanced / GeForce FX 5700 tab -- in newer drivers (v90 and above I believe) you have to click Control PAnel User Interface -> Classic nVidia Control Panel to enable the rest of the options there because they have an alternate GUI somewhere -- select Performance & Quality Settings, and set the slider to "High Performance".

2) Further, select View: Advanced Settings, set Trilinear Optimization: On, Anisotropic Sample Optimization: On, Anisotropic Mip Filter Optimization: Off. If you have RivaTuner installed, also adjust mipmap LOD bias to 0.3. You can now use decent quality anisotropic filter without much performance tax.

3) The most performance taxing option in SiN (and HL2) appears to be water, when set to Reflect All (r_waterforcereflectentities "1", r_waterforceexpensive "1"); make sure you select Simple Reflections (r_waterforcereflectentities "0", r_waterforceexpensive "0") or Reflect World (r_waterforcereflectentities "0", r_waterforceexpensive "1") instead -- due to a bug in the Source engine and material definitions, they are equivalent in DX8 modes -- if $forceExpensive is not defined for a material, r_waterforceexpensive "1" does not enable shader reflections either, nor does r_waterforceexpensive "0" disable them).

4) Do not set Texture Detail to "High" (mat_picmip "0") unless you have at least 1024M of RAM; use Medium/Low (mat_picmip "1" or "2") instead. nVidia drivers (unlike 3Dfx BTW) are system memory hogs.

5) As a last resort, set DX level to 7.0 (command line: +mat_dxlevel 70; console: mat_dxlevel 70, if you cannot do it in the Advanced Video Options menu for some reason). You will lose water reflections altogether.

--------------------
If you are not part of the solution, you are part of the problem. --Eldridge Cleaver
Pa3PyX is offline   Reply With Quote
Old 10-31-2006, 03:29 AM   #14
Pa3PyX
Casual
 
Pa3PyX's Avatar
 
Join Date: Oct 2006
Posts: 25
Send a message via ICQ to Pa3PyX Send a message via AIM to Pa3PyX Send a message via Yahoo to Pa3PyX
Default Re: choppy game

Quote:
Originally Posted by ChaosBahamut View Post
Put this under Launch Options.

-set dxlevel81

The FX series suck at DX9. That would be your problem most likely.
Not quite accurate I think; should be +mat_dxlevel 81 as a command line option. And all 5700 chips default to 8.1 already. But I have Athlon XP at 1900 MHz and FX 5700 Ultra and it's barely playable still (although comparable to HL2 of course).

1) In your GeForce control panel (right click display / Properties / Advanced / GeForce FX 5700 tab -- in newer drivers (v90 and above I believe) you have to click Control PAnel User Interface -> Classic nVidia Control Panel to enable the rest of the options there because they have an alternate GUI somewhere -- select Performance & Quality Settings, and set the slider to "High Performance".

2) Further, select View: Advanced Settings, set Trilinear Optimization: On, Anisotropic Sample Optimization: On, Anisotropic Mip Filter Optimization: Off. If you have RivaTuner installed, also adjust mipmap LOD bias to 0.3. You can now use decent quality anisotropic filter without much performance tax.

3) The most performance taxing option in SiN (and HL2) appears to be water, when set to Reflect All (r_waterforcereflectentities "1", r_waterforceexpensive "1"); make sure you select Simple Reflections (r_waterforcereflectentities "0", r_waterforceexpensive "0") or Reflect World (r_waterforcereflectentities "0", r_waterforceexpensive "1") instead -- due to a bug in the Source engine and material definitions, they are equivalent in DX8 modes -- if $forceExpensive is not defined for a material, r_waterforceexpensive "1" does not enable shader reflections either, nor does r_waterforceexpensive "0" disable them).

4) Do not set Texture Detail to "High" (mat_picmip "0") unless you have at least 1024M of RAM; use Medium/Low (mat_picmip "1" or "2") instead. nVidia drivers (unlike 3Dfx BTW) are system memory hogs.

5) Lower resolution; on the first blush it does not seem to affect much because video RAM bandwidth rarely is a bottleneck on modern video boards, but it does become a bottleneck for per pixel operations (blending -- smoke, fog; pixel shaders -- water reflection/refraction for instance) in high resolutions (above 1024 for 768 for my board, probably lower than that for yours). 1600x1200 and 640x480 may be equally fast in water-free area, but as soon as water is in the view, you will notice quite considerable difference.

6) As a last resort, set DX level to 7.0 (command line: +mat_dxlevel 70; console: mat_dxlevel 70, if you cannot do it in the Advanced Video Options menu for some reason). You will lose water reflections altogether.

--------------------
If you are not part of the solution, you are part of the problem. --Eldridge Cleaver

Last edited by Pa3PyX : 10-31-2006 at 03:36 AM.
Pa3PyX is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:11 AM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.