Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > SiN Episodes > SiN Episodes Tech Help

Reply
 
Thread Tools Display Modes
Old 05-12-2006, 07:00 PM   #26
urbanriot
Newbie
 
urbanriot's Avatar
 
Join Date: May 2006
Posts: 8
Default Re: Some graphics not rendering properly (skeleton

Quote:
Originally posted by Michael_Russell:Can you please go into the game, drop down the console, enable cheats (using sv_cheats 1),
Similar to the other person above, I can't utilize the console whatsoever, since it's filled with

<font class="small">Code:</font><hr /><pre>material engine/shadowbuild is being applied to a model, you need $model=1 in the .vmt file!</pre><hr />

It wouldn't let me copy this either, I had to write it manually.
urbanriot is offline   Reply With Quote
Old 05-12-2006, 07:31 PM   #27
Michael_Russell
Roaming QA Ronin
 
Michael_Russell's Avatar
 
Join Date: Dec 2004
Location: Dallas, TX
Posts: 887
Default Re: Some graphics not rendering properly (skeleton)

Okay, I've only been able to test this workaround on two systems, but it seems to be working. From what I can tell, for whatever reason, your cards weren't found in the override files, and as a result, all of the fallbacks were getting horked.

I'm going to be looking at this some more this weekend, but in the meantime, some of you should be able to fix this by doing the following:

Go to your C:\Program Files\Steam\SteamApps\[username]\sin episodes emergence\bin folder.
Delete the file vidcfg.bin. (Don't worry, it will get re-created later.)
Open your Steam Games list.
Right-click on "SiN Episodes: Emergence" and pick "Create desktop shortcut".
Right-click on the shortcut and add pick "Properties...".
Add "-dxlevel 90" to the end of the "Target" window, so the full string looks like this:

"C:\Program Files\Steam\Steam.exe" -applaunch 1300 -dxlevel 90

Run that shortcut once. When you get to the main menu, exit out, delete the desktop shortcut, and relaunch from the Steam games list.

That fixed it on two machines here, but there is no guarantee that this will work for everyone until I do some further testing.
Michael_Russell is offline   Reply With Quote
Old 05-12-2006, 07:45 PM   #28
trexdan
Newbie
 
Join Date: May 2006
Posts: 7
Default Re: Some graphics not rendering properly (skeleton

Sorry didnt work for me.
trexdan is offline   Reply With Quote
Old 05-12-2006, 08:51 PM   #29
Michael_Russell
Roaming QA Ronin
 
Michael_Russell's Avatar
 
Join Date: Dec 2004
Location: Dallas, TX
Posts: 887
Default Re: Some graphics not rendering properly (skeleton

I'm still digging deeper to see what could be causing this on the remainder of configs. If this works or doesn't work for other people, please post and let me know.
Michael_Russell is offline   Reply With Quote
Old 05-12-2006, 10:14 PM   #30
Michael_Russell
Roaming QA Ronin
 
Michael_Russell's Avatar
 
Join Date: Dec 2004
Location: Dallas, TX
Posts: 887
Default Re: Some graphics not rendering properly (skeleton)

One last question...

Has anyone on this thread validated their GCF's yet?

The reason I ask is that one of the error messages quoted earlier had a typo in it that doesn't appear in the executable or source code, and the typo was specifically called out. In addition, the textures mentioned already have the proper flags in their VTF's.

If you want to try validating your GCF's:

Load Steam
From the My Games tab, right-click on the game and select Properties from the menu.
Select the Local files tab and click the Verify integrity of game cache... button.
Steam will verify the game cache files (GCF's) - this process may take several minutes. Do not verify the cache files for multiple games simultaneously - as some games share cache files with other games, this may cause problems with verification.
Once the process is completed, the Check Window will automatically exit.
Michael_Russell is offline   Reply With Quote
Old 05-13-2006, 02:40 AM   #31
trexdan
Newbie
 
Join Date: May 2006
Posts: 7
Default Re: Some graphics not rendering properly (skeleton

Wow that worked perfectly!


Thanks alot!

Was my example what you were talking about?
trexdan is offline   Reply With Quote
Old 05-13-2006, 04:20 AM   #32
timeames85
Newbie
 
timeames85's Avatar
 
Join Date: May 2006
Location: Devon, UK
Posts: 5
Default Re: Some graphics not rendering properly (skeleton

Fixed here too!


Thanks!! [img]/forums/images/graemlins/grin.gif[/img]
timeames85 is offline   Reply With Quote
Old 05-13-2006, 12:10 PM   #33
urbanriot
Newbie
 
urbanriot's Avatar
 
Join Date: May 2006
Posts: 8
Default Re: Some graphics not rendering properly (skeleton

Validated GCF's, downloaded a few megs of files, everything works now.

Thanks!
urbanriot is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:20 AM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.