Ritualistic Forums

Go Back   Ritualistic Forums > Ritual Entertainment Games > SiN, SiN Steam & Wages of Sin

Reply
 
Thread Tools Display Modes
Old 10-31-1999, 09:21 AM   #1
sarumn
Casual
 
Join Date: Oct 1999
Location: carbondale, IL. USA
Posts: 41
Default does anyone have this prob with water animations?

This really isn't a "how to" question, but more of a "what the f*@k" question .

When I animate water in a map (not waves, just basic swirling texture) it is never animated when I test the map in 3DFX, but it is animated (most of the time anyway) when I run the map in software rendered mode.

Does anyone have any idea why. The only time I've seen animated water in 3DFX mode on a map that I've made (test or otherwise) is the very first time I tried it. After that nothing.
And just for the record I'm running a: K6-2 350
192 megs pc100 ram
voodoo3 pci
win98 SE
ohh. and I run my monitor at 1280x1024, and SIN in 800x600.

sarumn
sarumn@hotmail.com

[This message has been edited by sarumn (edited 10-31-99).]

[This message has been edited by sarumn (edited 10-31-99).]
sarumn is offline   Reply With Quote
Old 10-31-1999, 09:44 AM   #2
Aladdyn
Experienced
 
Join Date: May 1999
Location: penacook, nh usa
Posts: 146
Default Re: does anyone have this prob with water animations?

Well now that u mention it, i have some lava in my ctf level that i wanted to have animated, and i gave it a bunch of flags like warp, and tried to make it have waves but it wasnt doing anything when i compiled it, i just assumed it was cause i f-ed something up and i havnt bothered to check it yet. I was gonna worry about it later. Ill try to look into it today and get back to you about it unless someone here has an answer for u first.
Aladdyn is offline   Reply With Quote
Old 10-31-1999, 01:14 PM   #3
eutectic
Fanboy
 
Join Date: Jan 1999
Posts: 844
Default Re: does anyone have this prob with water animations?

Hmmm... this is a weird problem indeed. Never experienced that myself. Normally, to make water swirl, you have to set the "warp" surface flag on the water brush's top face and that's all there is to it. But I'm sure it's not set by default for water textures. You have to set it yourself in surf inspector.

Also, you can use warp on any kind of brush face you want and not just water brushes.

By what you said earlier, you must have the flag set otherwise you wouldn't see it at all in neither HW or SW rendering mode. The only thing I can see is that maybe you set another flag or field along with "warp" which may come in conflict with it.

Would you care to check your water brush in surf inspector and give a list of all the flags and field values that you changed?...

Or better yet, reset the brush texture to default and make sure only "water" is set on all the faces and "warp" only on the top face.

------------------
<a href=http://www.ritualistic.com/node>The Node</a>

The official Sin entities and scripting reference site

[This message has been edited by eutectic (edited 10-31-99).]
eutectic is offline   Reply With Quote
Old 11-01-1999, 12:18 AM   #4
sarumn
Casual
 
Join Date: Oct 1999
Location: carbondale, IL. USA
Posts: 41
Default Re: does anyone have this prob with water animations?

Thanks Aladdyn.

It's a weird prob. Well actually maybe not considering all the other probs people have in sied

Hell it could be that most times I'm just doing it wrong, but then again I searched around and couldn't find anything saying how to make the surface textures of water swirl (not wavey). For all I know it does it automatically, and I didn't realize it when I first got it to work.

sarumn
sarumn@hotmail.com
sarumn is offline   Reply With Quote
Old 11-02-1999, 01:10 PM   #5
sarumn
Casual
 
Join Date: Oct 1999
Location: carbondale, IL. USA
Posts: 41
Default Re: does anyone have this prob with water animations?

opps...forgot to post what happened.

I have figured out what I was doing wrong with wavey water. I gues you can't set "water" to be wavey and warped at the same time. Checking the warped button just freezes the waveing process and doesn't even warp the surface (unless I'm just doing this wrong, but I've tried it a number of different ways with the same result.)

So thanks eutectic, after reading your reply I looked at my surf ins. again and saw the prob.

Thanks again all, (your patience with this newbie is appreciated )

------------------
sarumn
"Addiction's a bitch when mappings your itch."
icq# 3052908
sarumn@hotmail.com


sarumn is offline   Reply With Quote
Old 11-03-1999, 02:18 PM   #6
eutectic
Fanboy
 
Join Date: Jan 1999
Posts: 844
Default Re: does anyone have this prob with water animations?

It's always a pleasure to help people who can listen and learn. And hey! We need more mappers anyway right?

I actually learned something here. I didn't know those 2 flags were incompatible with one another. So thanks for that.

On the other hand, there's an alternative you could use: texture translation or scrolling which is not at all incompatible with wavy water and actually looks pretty good IMO.

It doesn't have to be scripted but you may want to take a look at the example map and script I made and posted in the files section at the Node:

<a href=http://www.ritualistic.com/node/downloads/waves.zip>Waves</a>

That's if you haven't done so already. You also might want to refer to the trans_angle and trans_mag commands in the scripting section - surface commands. There's info in there on how to set the flags and fields in surface inspector for translating textures.

------------------
www.ritualistic.com/node

The official Sin entities and scripting reference site
eutectic is offline   Reply With Quote
Old 11-03-1999, 04:20 PM   #7
sock
Veteran
 
Join Date: May 1999
Location: WI, USA
Posts: 209
Default Re: does anyone have this prob with water animations?

Just a small note ...

If you are planning to use wavy/warp effects on brush surfaces be aware that the engine chops the brush up into 64x64 pieces and then creates 4 triangles from that brush. If you use this effect on large areas it will kill your r_speed and also slow down the engine a bit. Warp/wavy effects are really cool effects but they can easily kill your level.
Also light maps do not work on warp/wavy brushes very well that is why translate surfaces can often save the day.

Sock
sock is offline   Reply With Quote
Old 11-04-1999, 04:00 AM   #8
claudec
Fanatic
 
Join Date: Feb 1999
Location: Chicago
Posts: 1,736
Default Re: does anyone have this prob with water animations?

Too bad I didn't jump into this earlier I had the wavy/warp problem myself a while back. These two do not work together that is for sure.

Also I always figured wavy and warp taxed the game engine somehow because I don't see much of them in the original levels and when they are present, it's in a small area. Glad to see some confirmation of that

Now I wonder how taxing translating textures is?

claudec is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:43 PM.


Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.